Home > News > Set Up suPHP With PHP4 And PHP5

Set Up suPHP With PHP4 And PHP5

June 12th, 2006

This tutorial shows how to install and use suPHP with PHP4 and PHP5. suPHP is a tool for executing PHP scripts with the permissions of their owners instead of the Apache user. With the help of suPHP you can also have PHP4 and PHP5 installed at the same time which I will describe at the end of this article.

suPHP integrates into Apache2 as a module. At the time of this writing it does work with Apache2 prior to version 2.2. Version 2.2 is not supported yet.

This tutorial was written with the help of a Debian Sarge system, but as I compile suPHP from the sources here instead of installing some distribution specific suPHP packages, most of the steps should apply also to other distributions.Read Full Story

News

Comments are closed.